# Test running program from FlexPendant

**URL:** <https://tech-community.robotics.abb.com/t/test-running-program-from-flexpendant/969>\
**Category:** RobotStudio\
**Created:** [January 2, 2007, 5:05pm UTC](https://tech-community.robotics.abb.com/t/test-running-program-from-flexpendant/969 "2007-01-02T17:05:38Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bhanscom](https://avatars.discourse-cdn.com/v4/letter/b/5daacb/32.png) [@bhanscom](https://tech-community.robotics.abb.com/u/bhanscom)\
**Post date:** [January 2, 2007, 5:05pm UTC](https://tech-community.robotics.abb.com/t/test-running-program-from-flexpendant/969/1 "2007-01-02T17:05:38Z")

</div>

I have an active program loaded into RS5.07 that I am trying to test run using the Virtual Flex Pendant without any success. The problem is that when I try move the program pointer to the routine that I am trying to run, if I step through the routine, when I try to run a Move instruction, I get error messages stating that the client may not be in control and that required mastership could not be granted.

error message number: 20051

Could anyone explain what exactly is going on here and how to correct it?

Thanks,

Brian

---

<div class="post-metadata">

**Author:** ![Anders\_S](https://avatars.discourse-cdn.com/v4/letter/a/ce7236/32.png) [@Anders\_S](https://tech-community.robotics.abb.com/u/Anders_S)\
**Post date:** [January 5, 2007, 2:14pm UTC](https://tech-community.robotics.abb.com/t/test-running-program-from-flexpendant/969/2 "2007-01-05T14:14:34Z")

</div>

Hi Brian,

Unfortunately can this sometimes happen in RS 5.07. Normally will a warmstart of the VirtualController solve it.

We are working on this problem for future releases.

---

<div class="post-metadata">

**Author:** ![Cole](https://avatars.discourse-cdn.com/v4/letter/c/53a042/32.png) [@Cole](https://tech-community.robotics.abb.com/u/Cole)\
**Post date:** [April 3, 2007, 5:08am UTC](https://tech-community.robotics.abb.com/t/test-running-program-from-flexpendant/969/3 "2007-04-03T05:08:11Z")

</div>

I have been getting this problem with RS5.08 and warmstarts do not fix.

Has anyone found what is causing it?

---

<div class="post-metadata">

**Author:** ![sturner](https://dub1.discourse-cdn.com/flex005/user_avatar/tech-community.robotics.abb.com/sturner/32/3432_2.png) [@sturner](https://tech-community.robotics.abb.com/u/sturner)\
**Post date:** [April 3, 2007, 1:25pm UTC](https://tech-community.robotics.abb.com/t/test-running-program-from-flexpendant/969/4 "2007-04-03T13:25:23Z")

</div>

I am also getting this problm in 5.08.

I can not run the program from the Flexpendant and get Client not in controll errors. Write Access has not been resquested in RSO and I am not testing reachability in the station.

This is very very very annoying !

I need an explanation what to do next!
